zorruno wikki: Getting a newer version of handbrake-cli in debian

Getting a newer version of handbrake-cli in debian


Wanted for a plex post processing script
Debian is Buster (old stable at the time - Version 10)
I was planning to compile handbrake-cli

Found this
https://www.deb-multimedia.org/

and this is a good instruction
https://yeahlinux.com/how-to-install-latest-version-of-handbrake-debian/

cd /etc/apt/sources.list.d/; wget -q https://repo.b-cdn.net/debian-buster/multimedia-backports.list; wget -q http://www.deb-multimedia.org/pool/main/d/deb-multimedia-keyring/deb-multimedia-keyring_2016.8.1_all.deb; apt -y install ./deb-multimedia-keyring_2016.8.1_all.deb; rm -rf deb-multimedia-keyring_2016.8.1_all.deb; cd ~; apt update && apt upgrade -y


But buster is old stable now (not stable) so
 apt -t oldstable-backports search handbrake-cli 


then install with
 apt -t oldstable-backports install handbrake 


now
root@ostrich:/etc/apt/sources.list.d# apt search handbrake
Sorting... Done
Full Text Search... Done
handbrake/oldstable 1:1.2.2-dmo2 all
  Versatile DVD ripper and video transcoder

handbrake-cli/oldstable-backports,now 1:1.3.3-dmo0~bpo10+5 amd64 [installed]
  Versatile DVD ripper and video transcoder (command line)

handbrake-gtk/oldstable 1:1.2.2-dmo2 amd64
  Versatile DVD ripper and video transcoder (GTK GUI)



Last edited by ZorrUno
Mon, 06 Sep 2021 01:19 UTC [diff]


CategoryScripts
CategoryDebian
CategoryPlex